Shopkeeper и Jquery 3.0

На данный момент shopkeeper не совместим с новой версией Jquery 3.0. Просьба внести изменения, чтобы стал совместимым.

Можете migrate использовать например, и будет всё работать.

@Advanced Есть люди кто и не знает как этими средствами пользоваться. Лучше чтобы в следующем релизе была реализована совместимость.

Полностью поддерживаю, на данный момент разрабатываем сайты исключительно на новой версии jQuery 3.1.1 (Bootstrap 4 и uiKit 3). При попытке настроить tagManager 2, результат отрицательный. Фильтрация следовательно и само расширение не работает с jQuery отличным от версии 1.*. Пожалуйста, обратите внимание на данную проблему.

@SiTiS Уже добавлено в список задач на github.

@anton83 Да, но там размещен в теме Shopkeeper, а я прошу обратить внимание на tagManager. Мне кажется, так как это разные расширения, то и подход разный.

Пока вы можете сами сделать совместимость. Для этого надо
все .size() заменить на .length
и все jQuery(document).bind('ready', на jQuery(document).ready(

Участник @Andchir написал в Shopkeeper и Jquery 3.0:

.bind

А также еще нашел, что событие .bind () нужно заменить на событие .on ().

@Andchir проверил, вроде все работает как надо, огромное спасибо!

@SiTiS С shopkeeper тоже замечательно работает после правки.

@anton83 Подскажите, может я не там ищу, но у меня поиск не выдал этих строк кода. Где менять?

@Geminis С версии 3.2.6 все уже исправлено. Ничего искать и менять не нужно. Там по умолчанию поддержка Jquery 3.0 реализована.

Похоже, подключение к Форум | MODX Shopkeeper было разорвано, подождите, пока мы пытаемся восстановить соединение.