TagManager 2 - некорректная работа фильтра



  • Здравствуйте. На сайте используется TM2 для фильтрации и вывода товаров в категории. Сегодня заметил в одном месте некорректную работу, возможно встречается еще где-то, пока не анализировал. На против значения фильтра стоит число 8, то есть по этому фильтру есть 8 позиций и это действительно так:
    0_1467464634997_1.jpg
    Но при применении этого фильтра выводится только 6 товаров, два улетают куда-то. Эти две позиции не выводятся нигде, где применяется фильтр даже по другим параметрам. Если фильтры не применять, в категории этот товар есть, даже при применении пагинации и сортировке. Эти два ресурса ничем не отличаются от других ресурсов, которые выводятся корректно:
    0_1467464918155_2.jpg
    Сниппет вызывается так:

    <div id="products" itemscope itemtype="http://schema.org/ItemList">
    [[!tmCatalog?]]
    </div>
    

    Боюсь что это встречается и в других категориях, хотелось бы понять, в чем может быть дело.
    Modx 2.5.0 pl
    TM 2.3-pl


  • Администраторы

    Есть ссылка где посмотреть? Кэш чистили?



  • @Andchir Да, кеш чистил и руками удалял. Ссылка http://promsklad.com.ua/elektroinstrument/perforatoryi



  • @Andchir сказал TagManager 2 - некорректная работа фильтра:

    Есть ссылка где посмотреть? Кэш чистили?

    Прошу прощения. Разобрался, на этих позициях не указана цена, в таком случае они вылетают, если указать то все корректно работает!



  • Может быть у кого-то будет такая проблема, поэтому решил написать, каким образом она решилась у меня. У меня клиент вводил название бренда в одних товарах маленькими буквами, а в других большими. Получилось два разных бренда. Затем везде изменили на большие, но тогда получилась такая проблема, как описана здесь. Пришлось скопировать название в одном товаре и потом просто вставлять в других. После копипаста все стало на свои места. Очень странно, но именно так сработало.



Похоже, подключение к Форум | MODX Shopkeeper было разорвано, подождите, пока мы пытаемся восстановить соединение.