tagmanager2 не сортирует и не фильтрует

Здравствуйте!
В процессе редизайна сайта столкнулся с проблемой. Вот пример страницы каталога (http://design.alanmebel.by/kuhni/katalog-ramochnye-kuhni/). В "управлении фильтрами" все работает. На страницу выводятся все фильтры и их количество, но дальше ничего не происходит. Не работает ни сортировка, ни фильтрация. Точнее при попытке что либо сделать страница зависает. Ошибок в error.log и консоли браузеров нет. На сервере установлена версия mysql 5.5.

Может как-то поможет: некорректно работал AjaxForm - заработал после смены jquery-3.3.1 на jquery-3.2.1

MODX 2.6.3-pl, все приложения обновлены до актуальных

А если временно убрать AjaxForm со страницы? Вижу, что меняется URL аякс запроса при фильтрации, но какой скрипт это делает не понятно.

@andchir , Убрал все с AjaxForm. Ничего не изменилось.

Можно возвращать как было. У вас на сервере какие-то редиректы.

0_1528213149855_screenshot_004.png

Возможно, настройки Nginx (или Apache) или какой-то плагин.

@andchir , а что можно сделать и где что искать? Можете помочь? Могу дать доступ к сайту.

Покажите конфиг веб-сервера. Нгинкс или Апач?

Участник @andchir написал в tagmanager2 не сортирует и не фильтрует:

конфиг веб-сервера

Apache/2.2.26 (Unix) PHP/5.3.28
Версия клиента базы данных: libmysql - 5.6.25

Apache/2.2.26

Покажите содержимое .htacess.

@andchir

# MODX supports Friendly URLs via this .htaccess file. You must serve web
# pages via Apache with mod_rewrite to use this functionality, and you must
# change the file name from ht.access to .htaccess.
#
# Make sure RewriteBase points to the directory where you installed MODX.
# E.g., "/modx" if your installation is in a "modx" subdirectory.
#
# You may choose to make your URLs non-case-sensitive by adding a NC directive
# to your rule: RewriteRule ^(.*)$ index.php?q=$1 [L,QSA,NC]

RewriteEngine On
RewriteBase /



# Rewrite www.domain.com -> domain.com -- used with SEO Strict URLs plugin
RewriteCond %{HTTP_HOST} .
RewriteCond %{HTTP_HOST} ^www.(.*)$ [NC]
RewriteRule ^(.*)$ http://%1/$1 [R=301,L]
#
# or for the opposite domain.com -> www.domain.com use the following
# DO NOT USE BOTH
#
#RewriteCond %{HTTP_HOST} !^$
#RewriteCond %{HTTP_HOST} !^www\. [NC]
#RewriteCond %{HTTP_HOST} (.+)$
#RewriteRule ^(.*)$ http://www.%1/$1 [R=301,L] .


#
# or for the opposite domain.com -> www.domain.com use the following
# DO NOT USE BOTH
#

RewriteCond %{THE_REQUEST} ^GET.*index\.php [NC]
RewriteRule (.*?)index\.php/*(.*) /$1$2 [R=301,NE,L]

# The Friendly URLs part
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ index.php?q=$1 [L,QSA]





# Make sure .htc files are served with the proper MIME type, which is critical
# for XP SP2. Un-comment if your host allows htaccess MIME type overrides.

#AddType text/x-component .htc



# If your server is not already configured as such, the following directive
# should be uncommented in order to set PHP's register_globals option to OFF.
# This closes a major security hole that is abused by most XSS (cross-site
# scripting) attacks. For more information: http://php.net/register_globals
#
# To verify that this option has been set to OFF, open the Manager and choose
# Reports -> System Info and then click the phpinfo() link. Do a Find on Page
# for "register_globals". The Local Value should be OFF. If the Master Value
# is OFF then you do not need this directive here.
#
# IF REGISTER_GLOBALS DIRECTIVE CAUSES 500 INTERNAL SERVER ERRORS :
#
# Your server does not allow PHP directives to be set via .htaccess. In that
# case you must make this change in your php.ini file instead. If you are
# using a commercial web host, contact the administrators for assistance in
# doing this. Not all servers allow local php.ini files, and they should
# include all PHP configurations (not just this one), or you will effectively
# reset everything to PHP defaults. Consult www.php.net for more detailed
# information about setting PHP directives.

#php_flag register_globals Off



# For servers that support output compression, you should pick up a bit of
# speed by un-commenting the following lines.

#php_flag zlib.output_compression On
#php_value zlib.output_compression_level 5

php_flag display_errors off 
php_value error_reporting 0

# The following directives stop screen flicker in IE on CSS rollovers. If
# needed, un-comment the following rules. When they're in place, you may have
# to do a force-refresh in order to see changes in your designs.

#ExpiresActive On
#ExpiresByType image/gif A2592000
#ExpiresByType image/jpeg A2592000
#ExpiresByType image/png A2592000
#BrowserMatch "MSIE" brokenvary=1
#BrowserMatch "Mozilla/4.[0-9]{2}" brokenvary=1
#BrowserMatch "Opera" !brokenvary
#SetEnvIf brokenvary 1 force-no-vary

или какой-то плагин

Эта запись удалена!

@andchir
Еще раз спасибо за толчок "или какой-то плагин". На сайте стоял плагин RedirectToSlash:

<?php
if ($modx->event->name == 'OnLoadWebDocument') {
	$uri = $_SERVER['REQUEST_URI'];
	if ($modx->resource->isfolder && substr($uri, -1) != '/' && !$_GET['page']) {
		$modx->sendRedirect($modx->makeUrl($modx->resource->id),array('responseCode' => 'HTTP/1.1 301 Moved Permanently'));
	}
}

Отключил его и все заработало.

Похоже, подключение к Форум | MODX Shopkeeper было разорвано, подождите, пока мы пытаемся восстановить соединение.